
<!doctype html >
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->

<head>

<script>window.mrf={host:"bc.marfeel.com",dt:1},function(e,t,o,i,a,n,r){function d(){x&&(e.cookie="fromt=yes;path=/;expires="+new Date(Date.now()+18e5).toGMTString(),o.reload())}var x=!/marfeelgarda=no|fromt=yes/i.test(n+";"+a);if((/(ipad.*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9](?!.*mobile)|\bSilk\b/i.test(i)&&2&r.dt||/(ip(hone|od).*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9].*mobile|bb10/i.test(i)&&1&r.dt||/marfeelgarda=off/i.test(n))&&t===t.top){x&&e.write('<plaintext style="display:none">');var l="script",m=setTimeout(d,1e4),c=e.createElement(l),f=e.getElementsByTagName(l)[0];c.src="//bc.marfeel.com/statics/marfeel/gardac.js",c.onerror=d,c.onload=function(){clearTimeout(m)},f.parentNode.insertBefore(c,f)}}(document,window,location,navigator.userAgent,document.cookie,location.search,window.mrf);</script>
	
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
	
	
	
	<link href="https://cleantechnica.com/files/2013/07/ct-favicon.png" rel="shortcut icon"/>	
	

	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"> 
		
	
<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Drone Delivery by Geely | Selling Cars in the Age of COVID-19</title>
<meta name="description" content="Selling cars has been a handshake style business for over a century-- which is bad news in the age of COVID-19. Geely has a solution: drone delivery."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drone Delivery by Geely | Selling Cars in the Age of COVID-19" />
<meta property="og:description" content="Selling cars has been a handshake style business for over a century-- which is bad news in the age of COVID-19. Geely has a solution: drone delivery." />
<meta property="og:url" content="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/" />
<meta property="og:site_name" content="CleanTechnica" />
<meta property="article:publisher" content="https://www.facebook.com/CleanTechnica/" />
<meta property="article:tag" content="auto industry" />
<meta property="article:tag" content="car buying" />
<meta property="article:tag" content="China" />
<meta property="article:tag" content="coronavirus" />
<meta property="article:tag" content="COVID-19" />
<meta property="article:tag" content="drone delivery" />
<meta property="article:tag" content="drones" />
<meta property="article:tag" content="geely" />
<meta property="article:tag" content="geely bo rui" />
<meta property="article:tag" content="lotus" />
<meta property="article:tag" content="volvo" />
<meta property="article:section" content="Clean Transport" />
<meta property="article:published_time" content="2020-03-30T01:00:11+00:00" />
<meta property="article:modified_time" content="2020-03-30T00:20:22+00:00" />
<meta property="og:updated_time" content="2020-03-30T00:20:22+00:00" />
<meta property="og:image" content="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg" />
<meta property="og:image:secure_url" content="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="485" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Selling cars has been a handshake style business for over a century-- which is bad news in the age of COVID-19. Geely has a solution: drone delivery." />
<meta name="twitter:title" content="Drone Delivery by Geely | Selling Cars in the Age of COVID-19" />
<meta name="twitter:site" content="@cleantechnica" />
<meta name="twitter:image" content="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg" />
<meta name="twitter:creator" content="@cleantechnica" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://cleantechnica.com/#organization","name":"CleanTechnica","url":"https://cleantechnica.com/","sameAs":["https://www.facebook.com/CleanTechnica/","https://www.youtube.com/cleantechnica","https://twitter.com/cleantechnica"],"logo":{"@type":"ImageObject","@id":"https://cleantechnica.com/#logo","inLanguage":"en-US","url":"https://cleantechnica.com/files/2019/10/Logo_Clean_Technica_color.png","width":3692,"height":834,"caption":"CleanTechnica"},"image":{"@id":"https://cleantechnica.com/#logo"}},{"@type":"WebSite","@id":"https://cleantechnica.com/#website","url":"https://cleantechnica.com/","name":"CleanTechnica","inLanguage":"en-US","description":"Clean Tech News &amp; Views: Solar Energy News. Wind Energy News. EV News. &amp; More.","publisher":{"@id":"https://cleantechnica.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://cleantechnica.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#primaryimage","inLanguage":"en-US","url":"https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg","width":700,"height":485,"caption":"Geely Drone Delivery - selling cars during COVID-19"},{"@type":"WebPage","@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#webpage","url":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/","name":"Drone Delivery by Geely | Selling Cars in the Age of COVID-19","isPartOf":{"@id":"https://cleantechnica.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#primaryimage"},"datePublished":"2020-03-30T01:00:11+00:00","dateModified":"2020-03-30T00:20:22+00:00","description":"Selling cars has been a handshake style business for over a century-- which is bad news in the age of COVID-19. Geely has a solution: drone delivery."},{"@type":"Article","@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#article","isPartOf":{"@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#webpage"},"author":{"@id":"https://cleantechnica.com/#/schema/person/1839ef4c491f6c47d421d641e466d4af"},"headline":"Drone Delivery By Geely: Selling Cars In The Age Of COVID-19","datePublished":"2020-03-30T01:00:11+00:00","dateModified":"2020-03-30T00:20:22+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#webpage"},"publisher":{"@id":"https://cleantechnica.com/#organization"},"image":{"@id":"https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/#primaryimage"},"keywords":"auto industry,car buying,China,coronavirus,COVID-19,drone delivery,drones,geely,geely bo rui,lotus,volvo","articleSection":"Cars,Clean Transport,Electric Cars,Electric Vehicles,Hybrid Electric Cars,PHEV","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://cleantechnica.com/#/schema/person/1839ef4c491f6c47d421d641e466d4af","name":"Jo Borr\u00e1s","image":{"@type":"ImageObject","@id":"https://cleantechnica.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a57f27277f3d7314dea29e817573aecb?s=96&d=identicon&r=g","caption":"Jo Borr\u00e1s"},"description":"I've been involved in motorsports and tuning since 1997, and have been a part of the Important Media Network since 2008.  You can find me here, working on my Volvo fansite, riding a motorcycle around Chicago, or chasing my kids around Oak Park.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CleanTechnica &raquo; Feed" href="https://cleantechnica.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CleanTechnica &raquo; Comments Feed" href="https://cleantechnica.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CleanTechnica &raquo; Drone Delivery By Geely: Selling Cars In The Age Of COVID-19 Comments Feed" href="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cleantechnica.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='main_css-css'  href='https://cleantechnica.com/wp-content/themes/gonzo/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-consent-style-css'  href='https://cleantechnica.com/wp-content/plugins/uk-cookie-consent/assets/css/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dpsp-frontend-style-css'  href='https://cleantechnica.com/wp-content/plugins/social-pug/assets/css/style-frontend.css?ver=5.3.2' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://cleantechnica.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='ubiquity_widget_style-css'  href='https://cleantechnica.com/wp-content/plugins/ubiquity_v2/css/ubiq_widgets.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var gonzo_script = {"post_id":"205484","ajaxurl":"https:\/\/cleantechnica.com\/wp-admin\/admin-ajax.php"};
var gonzo_script = {"post_id":"205484","ajaxurl":"https:\/\/cleantechnica.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/themes/gonzo/js/libs/modernizr-2.0.6.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/themes/gonzo/js/scripts.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cssTarget = "img.style-svg";
var ForceInlineSVGActive = "false";
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/svg-support/js/min/svgs-inline-min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/social-pug/assets/js/front-end.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/themes/gonzo/js/adshider.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/ubiquity_v2/scripts/ubiquity.social.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://cleantechnica.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cleantechnica.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cleantechnica.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://cleantechnica.com/?p=205484' />
      <meta property="og:title" content="Drone Delivery By Geely: Selling Cars In The Age Of COVID-19"/>
      <meta property="og:type" content="article"/>
      <meta property="og:url" content="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/"/>
				<meta property="og:image" content="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1-150x150.jpg"/>
		      <meta property="og:site_name" content="CleanTechnica"/> 
      <meta property="og:description" content="You've really got to feel for the carmakers of the world right. I mean, you've got to feel for everyone right now, but I'm a car guy and I needed an introduction to a story about how hard it is to actually sell a new car or motorcycle in the age of COVID-19 during the"/>
            <meta property="fb:app_id" content="107162296009995" />
          <script type="text/javascript">

      window.__afterConsentExecute = function() {
<script async custom-element="amp-analytics"
src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js">
</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-18444479-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-18444479-1');
</script>


<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '438121713776676'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=438121713776676&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->
</script>

<script src="//m2d.m2.ai/m2d.cleantechnica.js" async ></script>

 

<meta name="google-site-verification" content="S-vmNeFa-nGQ_zgPxkku8ocG2ORA3_juHlMADIAEUVE" /><style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><style type="text/css" data-source="Social Pug">
					@media screen and ( max-width : 720px ) {
						#dpsp-floating-sidebar.dpsp-hide-on-mobile { display: none !important; }
					}
				
					@media screen and ( max-width : 720px ) {
						.dpsp-content-wrapper.dpsp-hide-on-mobile { display: none !important; }
					}
				</style><meta name="twitter:card" 		content="summary_large_image" /><meta property="og:url"			content="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/" /><meta property="og:type"			content="article" /><meta property="og:title"			content="Drone Delivery By Geely: Selling Cars In The Age Of COVID-19" /><meta property="og:description" 	content="The whole process is incredibly polished, and could set the standard by which direct-to-consumer sales start to happen globally. That&#039;s especially significant these days, too, now that the laws surrounding dealerships and franchises continue to get challenged by upstart EV makers. Heck, even the keys themselves are next-level -- take a look for yourself!" /><meta property="og:image" 		content="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1-570x395.jpg" /><link rel="amphtml" href="https://cleantechnica.com/2020/03/29/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19/amp/">			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/*** Blockquote Fix ***/

#omc-logo
{width: 276px;
	height: 50px;
	
	}			</style>
			
	<!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://cleantechnica.com/wp-content/themes/gonzo/css/ie8.css" /><![endif]-->
	
	<!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://cleantechnica.com/wp-content/themes/gonzo/css/ie7.css" /><![endif]-->
	
	
	<link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
	
		
	<noscript>
		<style>
			.es-carousel ul{display:block;}
		</style>
	</noscript>	
	
	<style>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</style>
	
</head>

<body class="post-template-default single single-post postid-205484 single-format-standard" >
<center><div id="MM_CT_desktop_top_728x90"></div></center>
	<div id="fb-root">
	</div>
	<script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0];  if (d.getElementById(id)) return;  js = d.createElement(s); js.id = id;  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";  fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>

	<div id="omc-transparent-layer">
	
	<!-- <div class="preloaders" style=""></div>  -->
		
				
			<div id="omc-top-menu">
				
				<div class="omc-top-menu-inner"><ul id="menu-top-menu" class="menu"><li id="menu-item-170631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170631"><a href="https://cleantechnica.com/invest/">Invest</a></li>
<li id="menu-item-132206" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132206"><a href="http://products.cleantechnica.com/cars">Electric Cars</a></li>
<li id="menu-item-136011" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136011"><a href="https://cleantechnica.com/2016/08/31/30-reasons-next-car-electric/">Electric Car Benefits</a></li>
<li id="menu-item-136012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136012"><a href="https://cleantechnica.com/tag/ev-sales/">Electric Car Sales</a></li>
<li id="menu-item-133660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-133660"><a href="https://cleantechnica.com/2013/10/08/advantages-disadvantages-solar-power/">Solar Energy Rocks</a></li>
<li id="menu-item-79707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79707"><a href="http://cleantechnica.com/feed">RSS</a></li>
<li id="menu-item-55793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55793"><a href="http://cleantechnica.com/advertise/">Advertise</a></li>
<li id="menu-item-148986" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148986"><a href="https://cleantechnica.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>				
				<br class="clear" />
				
			</div>
		
				
		<div id="omc-container">
			
			<header>
			
				
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="omc-top-banner">
<div class="hjawidget textwidget">
<center><h3><small>#1 electric vehicle, solar, & battery news + analysis site in the world. <span style="color: #85d2eb;"><a href="https://future-trends.cleantechnica.com/subscribe/"><span style="color: #85d2eb;">Support our work today</a></span></span>.</small></h3>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
	
				
				<a id="omc-logo" href="https://cleantechnica.com"><img src="https://cleantechnica.com/files/2019/09/Logo_Clean_Technica_sign_separately-04.svg" alt="CleanTechnica logo"  /></a>
					
				<nav id="omc-main-navigation">				
				
										
					<div class="omc-over-480"><ul id="menu-bottom-menu" class="menu"><li id='menu-item-53429'  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a  href="http://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/">Exclusives</a> 
<ul class="sub-menu">
<li id='menu-item-156152'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://products.cleantechnica.com/reports/">CleanTechnica Reports</a> </li>
<li id='menu-item-74303'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/">All Exclusives</a> </li>
<li id='menu-item-74305'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/cleantechnica-reviews/">CleanTechnica Reviews</a> </li>
<li id='menu-item-74300'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/cleantechnica-reports/">CleanTechnica Original News</a> </li>
<li id='menu-item-74301'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/cleantechnica-videos/">CleanTechnica Videos</a> </li>
<li id='menu-item-139558'  class="menu-item menu-item-type-post_type menu-item-object-page"><a  href="https://cleantechnica.com/reality-check-correcting-cleantech-record/">Reality Check — Correcting the Cleantech Record</a> </li>
<li id='menu-item-98188'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/cleantech-talk/">Cleantech Talk (Our Podcast)</a> </li>
<li id='menu-item-156150'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/tesla-model-3-long-term-review/">Tesla Model 3 Long-Term Review</a> </li>
<li id='menu-item-98190'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/tesla-model-s-long-term-review/">Tesla Model S Long-Term Review</a> </li>
<li id='menu-item-98189'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/nissan-leaf-long-term-review/">Nissan LEAF Long-Term Review</a> </li>
<li id='menu-item-156151'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/bmw-i3-long-term-review/">BMW i3 Long-Term Review</a> </li>
</ul>
</li>
<li id='menu-item-92086'  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a  href="https://cleantechnica.com/category/cleantechnica-2/cleantechnica-exclusive/cleantechnica-reviews/">EV Reviews</a> 
<ul class="sub-menu">
<li id='menu-item-52038'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://products.cleantechnica.com/cars">Electric Cars For Sale In 2018 (USA)</a> </li>
<li id='menu-item-92115'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/08/18/audi-a3-e-tron-test-drive-review/">Audi A3 e-tron</a> </li>
<li id='menu-item-92126'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2013/11/24/review-bmw-i3-videos/">BMW i3 (2013)</a> </li>
<li id='menu-item-136197'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/07/20/24-hours-new-longer-range-2017-bmw-i3-cleantechnica-exclusive/">BMW i3 (2017)</a> </li>
<li id='menu-item-136199'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/05/28/electric-car-road-trip-zoomin-usa-part-3-3/">BMW i3 REx (2017)</a> </li>
<li id='menu-item-92119'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2014/10/07/bmw-i3-vs-mercedes-b-class-electric-exclusive/">BMW i3 vs Mercedes B-Class Electric</a> </li>
<li id='menu-item-92112'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/10/31/nissan-leaf-vs-chevy-volt-vs-bmw-i3/">BMW i3 vs Nissan LEAF vs Chevy Volt</a> </li>
<li id='menu-item-92111'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/10/31/bmw-i3-vs-tesla-model-s-the-dilemma-continues/">BMW i3 vs Tesla Model S 70D</a> </li>
<li id='menu-item-92113'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/10/27/i8-vs-model-s-vs-elr-vs-panamera-s-e-hybrid-vs-i3-exclusive/">BMW i8 vs Tesla Model S vs Cadillac ELR vs Porsche Panamera S E-Hybrid vs BMW i3</a> </li>
<li id='menu-item-136233'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/12/19/chanje-electric-van-serious-fleet-industry-game-changer-cleantechnica-review-part-1/">Chanje Electric Van</a> </li>
<li id='menu-item-92127'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2013/09/19/2014-chevy-spark-ev-test-drive-ct-exclusive/">Chevy Spark EV</a> </li>
<li id='menu-item-136200'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/05/18/24-hours-with-the-2017-chevy-bolt/">Chevy Bolt</a> </li>
<li id='menu-item-136198'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/06/25/life-chevy-bolt-first-1200-miles/">Chevy Bolt (Owner Review)</a> </li>
<li id='menu-item-92114'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/10/03/2016-chevy-volt-exclusive-cleantechnica-review-pictures/">Chevy Volt (2016)</a> </li>
<li id='menu-item-136204'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2016/12/30/2017-chevy-volt-vs-2015-nissan-leaf-test-drive-comparison/">Chevy Volt vs Nissan LEAF</a> </li>
<li id='menu-item-92124'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2013/12/27/2013-chevrolet-volt-1-year-cost-ownership-review/">Chevy Volt Cost of Ownership</a> </li>
<li id='menu-item-136190'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/10/08/chrysler-pacifica-plug-in-hybrid-review/">Chrysler Pacifica Plug-In Hybrid</a> </li>
<li id='menu-item-136186'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/11/19/emotorwerks-juicebox-pro-40-evse-review-cleantechnica-exclusive/">eMotorWerks JuiceBox Pro 40</a> </li>
<li id='menu-item-103311'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://evobsession.com/fiat-500e-review/">Fiat 500e (2015)</a> </li>
<li id='menu-item-136202'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/02/04/fiat-500e-review-biker-chick/">Fiat 500e (2016)</a> </li>
<li id='menu-item-136205'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2016/12/01/ford-focus-electric-review-extreme-depth/">Ford Focus Electric</a> </li>
<li id='menu-item-136191'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/09/09/hyundai_ioniq_electric_vehicle_review/">Hyundai Ioniq Electric</a> </li>
<li id='menu-item-136184'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/11/27/jac-iev7s-review-big-step-2017-jac-iev6s/">JAC iEV7S</a> </li>
<li id='menu-item-136187'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/10/28/kia-soul-ev-review-cleantechnica-exclusive/">Kia Soul EV</a> </li>
<li id='menu-item-136185'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/kia-soul-ev-long-term-review/">Kia Soul EV Long-Term Review</a> </li>
<li id='menu-item-136201'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/02/14/lucid-motors-air-indeed-lucid-vision-original-review-test-ride-part-1/">Lucid Air</a> </li>
<li id='menu-item-92110'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/11/02/mercedes-b-class-electric-drive-one-year-later-cleantechnica-exclusive/">Mercedes B-Class Electric Drive</a> </li>
<li id='menu-item-136195'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/08/06/goodbye-mitsubishi-miev-first/">Mitsubishi i-MiEV</a> </li>
<li id='menu-item-92117'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/07/28/mitsubishi-outlander-plug-in-test-drive-exclusive-review/">Mitsubishi Outlander PHEV</a> </li>
<li id='menu-item-92139'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/tag/nissan-leaf-long-term-review/">Nissan LEAF Long-Term Review</a> </li>
<li id='menu-item-136206'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2016/10/29/comparing-nissan-leaf-cadillac-xts-luxury-sedan/">Nissan LEAF vs Cadillac XTS</a> </li>
<li id='menu-item-136183'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/11/30/new-nissan-leaf-facelift-2017-la-auto-show-2017-interview-test-drive/">Nissan LEAF (2018)</a> </li>
<li id='menu-item-92123'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2014/01/07/review-renault-twizy/">Renault Twizy</a> </li>
<li id='menu-item-92116'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/08/16/renault-zoe-test-drive-review-exclusive/">Renault Zoe</a> </li>
<li id='menu-item-92122'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2014/01/07/review-smart-electric-drive/">Smart Electric Drive</a> </li>
<li id='menu-item-92120'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2014/09/10/sold-camaro-bought-electric-car/">Smart Electric Drive vs Camaro</a> </li>
<li id='menu-item-138022'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2018/01/13/tesla-model-3-review-cleantechnica-exclusive/">Tesla Model 3</a> </li>
<li id='menu-item-98185'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/tag/tesla-model-s-long-term-review/">Tesla Model S 85D Long-Term Review</a> </li>
<li id='menu-item-136192'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/08/31/tesla-autopilot-2-months-later/">Tesla Model S Autopilot (1st Gen)</a> </li>
<li id='menu-item-136193'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/08/31/tesla-navigation-goods-bads/">Tesla Model S Navigation</a> </li>
<li id='menu-item-136196'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/07/22/tesla-superchargers-vs-ugh/">Tesla Superchargers</a> </li>
<li id='menu-item-136188'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/10/25/tesla-model-s-poland-paris-poland-photo-essay/">Tesla Model S Road Trip (Europe)</a> </li>
<li id='menu-item-92118'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2015/05/25/tesla-p85d-test-drive-reactions-5-videos/">Tesla Model S P85D</a> </li>
<li id='menu-item-103310'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2016/04/12/my-tesla-model-x-90d-test-drive-this-suv-blows-me-away-videos/">Tesla Model X 90D Review #1, by Zach</a> </li>
<li id='menu-item-103309'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2016/04/17/tesla-levels-suv-model-x-exclusive-model-x-review/">Tesla Model X 90D Review #2, by Kyle</a> </li>
<li id='menu-item-136194'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/08/13/the-toyota-prius-prime-hints-at-the-electric-future-of-toyota-cleantechnica-exclusive/">Toyota Prius Prime</a> </li>
<li id='menu-item-92121'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2014/08/26/tale-two-golfs-2015-vw-e-golf-first-drive/">Volkswagen e-Golf</a> </li>
<li id='menu-item-92125'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="http://cleantechnica.com/2013/12/04/vw-e-review-videos-pictures/">Volkswagen e-Up!</a> </li>
<li id='menu-item-115990'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/01/19/2017-volvo-xc90-t8-plug-hybrid-test-drive-review/">Volvo XC90 T8</a> </li>
<li id='menu-item-136189'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/2017/10/24/exclusive-workhorse-e-gen-electric-truck-begins-tests-wb-mason-cleantechnica-test-drive/">Workhorse E-Gen</a> </li>
</ul>
</li>
<li id='menu-item-136018'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/category/clean-transport-2/">EV News</a> </li>
<li id='menu-item-52036'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/tag/tesla/">Tesla News</a> </li>
<li id='menu-item-136017'  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a  href="https://cleantechnica.com/category/clean-energy/">Electricity</a> 
<ul class="sub-menu">
<li id='menu-item-46121'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/clean-energy/solar-energy/">Solar Energy</a> </li>
<li id='menu-item-46122'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/clean-energy/wind-energy/">Wind Energy</a> </li>
<li id='menu-item-46131'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/clean-energy/geothermal-energy/">Geothermal Energy</a> </li>
<li id='menu-item-46145'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/energy-storage/">Energy Storage</a> </li>
<li id='menu-item-46144'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/grid/smart-grid/">Smart Grid</a> </li>
<li id='menu-item-46128'  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a  href="https://cleantechnica.com/category/energy-efficiency/">Energy Efficiency</a> 
	<ul class="sub-menu">
<li id='menu-item-46651'  class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://cleantechnica.com/category/energy-efficiency/lighting/">Lighting</a> </li>
	</ul>
</li>
</ul>
</li>
<li id='menu-item-52027'  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a  href="http://cleantechnica.com/cleantechnica/">About</a> 
<ul class="sub-menu">
<li id='menu-item-52146'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/cleantechnica/">About</a> </li>
<li id='menu-item-191028'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/cleantech-talk/">Our Podcast</a> </li>
<li id='menu-item-175876'  class="menu-item menu-item-type-post_type menu-item-object-page"><a  href="https://cleantechnica.com/cleantechnica-newsletters/">CleanTechnica Newsletters</a> </li>
<li id='menu-item-120836'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/advertise/">Advertise</a> </li>
<li id='menu-item-52030'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/contact/">Contact Us</a> </li>
<li id='menu-item-52028'  class="menu-item menu-item-type-custom menu-item-object-custom"><a  href="https://cleantechnica.com/our-team/">Our Team</a> </li>
<li id='menu-item-138691'  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy"><a  href="https://cleantechnica.com/privacy-policy/">Privacy Policy</a> </li>
</ul>
</li>
<li id="omc-header-search">				
						<span id="omc-search-overlay">Search &rarr;</span>
						<form method="get" id="desktop-search" class="omc-search-form" action="https://cleantechnica.com/">
							<input type="text" class="omc-header-search-input-box" value=""  name="s" id="fffff">
							<input type="submit" class="omc-header-search-button" id="searchsubmit" value="">
						</form>
					</li></ul></div>					
										
					<br class="clear" />
					
											
					<div id="omc-header-search-mobi">		
					
						<form method="get" id="mobi-search" class="omc-mobi-search-form" action="https://cleantechnica.com/">
						
							<input type="text" class="omc-header-mobi-search-input-box" value=""  name="s" id="mobi-mobi-search">
							
							<input type="submit" class="omc-header-mobi-search-button" id="seadssdrchsubmit" value="">
							
						</form>
						
					</div>	
						
				</nav>
				
				<br class="clear" />				
				
			</header>
<section id="omc-main">	

	<article id="omc-full-article" class="omc-inner-standard">
		
		
    
    <div id="omc-inner-placeholder">

        <a href="https://cleantechnica.com/category/clean-transport-2/cars/" class="omc-flex-category">Cars</a>        
        <img src="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1-620x350.jpg" class="featured-full-width-top wp-post-image" alt="Geely Drone Delivery - selling cars during COVID-19" />
        
        <div class="omc-article-top">

            <p class="omc-date-time-inner omc-format-standard">
                <b>Published on</b> March 29th, 2020 |
                <em>by Jo Borrás</em></p>
            
                
                <span class="omc-comment-count"><span class="dsq-postid" data-dsqidentifier="205484 https://cleantechnica.com/?p=205484">0</span></span>
                
        </div>
        <!-- /omc-article-top-->

    </div><!-- /omc-inner-placeholder -->

        
<h1 class="omc-post-heading-standard">Drone Delivery By Geely: Selling Cars In The Age Of COVID-19</h1>

    <div id="dpsp-content-top" class="dpsp-content-wrapper dpsp-shape-rounded dpsp-column-auto dpsp-has-spacing dpsp-hide-on-mobile dpsp-button-style-1 dpsp-has-icon-background dpsp-has-button-background">
<ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content ">
<li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=Drone%20Delivery%20By%20Geely%3A%20Selling%20Cars%20In%20The%20Age%20Of%20COVID-19&#038;url=https%3A%2F%2Fcleantechnica.com%2F2020%2F03%2F29%2Fdrone-delivery-by-geely-selling-cars-in-the-age-of-covid-19%2F" class="dpsp-network-btn dpsp-twitter dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span></span></a></li>
<li><a rel="nofollow" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fcleantechnica.com%2F2020%2F03%2F29%2Fdrone-delivery-by-geely-selling-cars-in-the-age-of-covid-19%2F&#038;title=Drone%20Delivery%20By%20Geely%3A%20Selling%20Cars%20In%20The%20Age%20Of%20COVID-19&#038;mini=true" class="dpsp-network-btn dpsp-linkedin"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li>
<li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcleantechnica.com%2F2020%2F03%2F29%2Fdrone-delivery-by-geely-selling-cars-in-the-age-of-covid-19%2F&#038;t=Drone%20Delivery%20By%20Geely%3A%20Selling%20Cars%20In%20The%20Age%20Of%20COVID-19" class="dpsp-network-btn dpsp-facebook dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span></span></a></li>
</ul>
</div>
<p><span>March 29th, 2020</span> by <strong><span style="color: #85d2eb;"><a href="https://cleantechnica.com/author/joborras/"  rel="author">Jo Borrás</a></span></strong>&nbsp;</p>
<hr />
<p align="justify">You&#8217;ve really got to feel for the carmakers of the world right. I mean, you&#8217;ve got to feel for <em>everyone</em> right now, but I&#8217;m a car guy and I needed an introduction to a story about how hard it is to actually sell a new car or motorcycle <del>in the age of COVID-19</del> during the Coronapocalypse. Part of what makes it difficult, beyond the economic uncertainty, is the actual act of getting to the dealer and &#8212; Gasp! &#8212; shaking hands with the salespeople. Luckily, Geely has figured out a solution: <strong>drone delivery</strong>.</p>
<div id="attachment_205486" style="width: 710px" class="wp-caption aligncenter"><a href="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg" rel="attachment wp-att-205486"><img aria-describedby="caption-attachment-205486" class="wp-image-205486 size-full"  src="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg" alt="Geely Drone Delivery - selling cars during COVID-19" width="700" height="485" srcset="https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1.jpg 700w, https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1-270x187.jpg 270w, https://cleantechnica.com/files/2020/03/Drone-delivery-700x485-1-570x395.jpg 570w" sizes="(max-width: 700px) 100vw, 700px" /></a></p>
<p id="caption-attachment-205486" class="wp-caption-text">Image by Geely</p>
</div>
<p align="justify">If you&#8217;re not familiar with Geely, you&#8217;re certainly familiar with some of the companies it owns, namely <a href="https://cleantechnica.com/2020/03/27/volvo-moves-to-rail-transport-to-slash-carbon-emissions/">Volvo</a> and <a href="https://cleantechnica.com/2019/11/25/2000-hp-electric-lotus-evija-makes-its-racetrack-debut-video/">Lotus Cars</a>, each EV and tech pioneers in their own right. The Geely Bo Rui GE PHEV (pronounced &#8220;Bow Ray&#8221;), for example, is built using the same CMA architecture found in <a href="https://cleantechnica.com/2019/10/16/volvo-takes-the-wraps-off-the-fully-electric-xc40-dives-into-vehicle-electrification/">the award-winning Volvo XC40</a>, and it is <em>slick</em>. <a href="http://www.volvojo.com/2018/06/02/geely-bo-rui-ge-first-to-get-volvo-mhev-tech/" target="_blank" rel="noopener noreferrer">You can learn more about the Bo Rui by clicking here</a>, but that&#8217;s not what this post is about. <a href="http://global.geely.com/media-center/news/geely-auto-launches-full-online-car-buying-and-home-delivery-service/" target="_blank" rel="noopener noreferrer">What this post is about is Geely&#8217;s brilliant combination of online configuration</a>, ordering, purchasing, and&#8211; finally!&#8211; the drone delivery of your new Geely&#8217;s keys.</p>
<p align="justify">The whole process is incredibly polished, and could set the standard by which direct-to-consumer sales start to happen globally. That&#8217;s especially significant these days, too, <a href="https://cleantechnica.com/2020/03/02/colorado-senate-passes-bill-allowing-tesla-rivian-sales/">now that the laws surrounding dealerships and franchises continue to get challenged by upstart EV makers</a>. Heck, even the keys themselves are next-level &#8212; take a look for yourself!</p>
<h4 style="text-align: center;">Geely Bo Rui GE SmartKey</h4>
<div id="attachment_205496" style="width: 860px" class="wp-caption aligncenter"><a href="https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1.jpg" rel="attachment wp-att-205496"><img aria-describedby="caption-attachment-205496" class="wp-image-205496 size-full"  src="https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1.jpg" alt="Geely Bo Rui GE SmartKey" width="850" height="423" srcset="https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1.jpg 850w, https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1-270x134.jpg 270w, https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1-570x284.jpg 570w, https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1-768x382.jpg 768w, https://cleantechnica.com/files/2020/03/Geely-Bo-Rui-GE-30-850x423-1-620x310.jpg 620w" sizes="(max-width: 850px) 100vw, 850px" /></a></p>
<p id="caption-attachment-205496" class="wp-caption-text">Image by Geely</p>
</div>
<p align="justify">It&#8217;s worth noting, too, that Geely&#8217;s drone delivery thing &#8212; while definitely a timely gimmick &#8212; isn&#8217;t an isolated thing. The Geely ICON (shown in the image, above) is said to be China&#8217;s first mass-produced vehicle equipped an anti-bacterial cabin filter. <a href="https://cleantechnica.com/2019/04/09/tesla-bioweapon-defense-mode-with-memory-smart-powerwall-storm-watch-teslas-software-superiority/">Think of Tesla&#8217;s Bioweapon Defense Mode</a>, and you&#8217;ll get the idea. In addition to that, Geelys purchased online &#8220;are thoroughly disinfected by the dealership including through ionization prior to delivery in order to ensure customers enjoy a safe and healthy purchase experience.&#8221;</p>
<p align="justify">Geely&#8217;s other companies appear to be following suit, too, if emails I&#8217;ve received announcing similar &#8220;disinfecting&#8221; steps being taken at two Chicago-area Volvo dealerships (<a href="https://www.volvooakpark.com/" target="_blank" rel="noopener noreferrer">Volvo Oak Park</a> and <a href="https://www.patrickvolvocars.com/" target="_blank" rel="noopener noreferrer">Patrick Volvo</a>) are any indication.</p>
<p align="justify">What do you guys think? Would you buy a car totally online and have your documents and keys sent over by drone delivery, or would you prefer to interact with a human being at a car dealership and, maybe, negotiate yourself a better deal than you might be able to get online? Check out Geely&#8217;s official press release and video, below, then let us know what you think in the comments.</p>
<h4 style="text-align: center;">Geely Auto Goes Full Contactless with New Car Keys Being Delivered by Drone</h4>
<p><iframe  width="900" height="506" src="https://www.youtube.com/embed/NxUK2UmzFV8?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>&nbsp;</p>
<p style="padding-left: 40px;" align="justify"><strong>Hangzhou, China</strong> &#8212; <em>Geely Auto launched its own proprietary online sales system that offered consumers the complete one stop solution for ordering online that included the modification of vehicle specifications, online financing and insurance as well as giving the option of establishing a home delivery in a contactless solution.</em></p>
<p style="padding-left: 40px;" align="justify"><em>Geely Auto has also improved upon its contactless home delivery system which looks to directly deliver new vehicles to consumers’ homes or place of work rather than collecting from dealerships. The new system will now use drones in select locations to pass new car keys to consumers by delivering directly to their door or balcony, furthering the distance between staff and consumer and creating a truly contactless process.</em></p>
<p style="padding-left: 40px;" align="justify"><em>Since the platform was launched in February, just over 10,000 consumers have ordered and paid for vehicles on Geely’s online mall with a further 110,000 users registering their interest to buy a Geely vehicle in the short term. All confirmed orders and confirmed leads are a sent to local dealers who process orders and begin the home delivery process.</em></p>
<p style="padding-left: 40px;" align="justify"><em>All Geely Auto vehicles are thoroughly disinfected by the dealership including through ionization prior to delivery in order to ensure customers enjoy a safe and healthy purchase experience. As part of Geely’s commitment to developing healthy cars, Geely Auto has set aside a 370 million RMB fund that will focus on the development of cleaner, healthier vehicles providing clean cabin air and using materials that are antimicrobial in nature. The first mass produced vehicle equipped with anti-bacterial filters, the Geely ICON (shown), that was launched in late February 2020.</em></p>
<p style="padding-left: 40px;" align="justify"><em>Victor Yang, Vice President of Geely Auto Sales Company commented: “Geely Auto’s constant change to market requirements and consumer concerns is the driving force behind Geely’s continued success in the Chinese market.”</em></p>
<p><strong>Source | Images</strong>: <a href="http://global.geely.com/media-center/news/geely-auto-goes-full-contactless-with-new-car-keys-being-delivered-by-drone/" target="_blank" rel="noopener noreferrer">Geely Global Media</a>.&nbsp;<br />
&nbsp;</p>
<p><a href="https://cleantechnica.com/files/2019/10/Google-News-icon.png"><img class="alignleft size-full wp-image-192998" src="https://cleantechnica.com/files/2019/10/Google-News-icon.png" alt="" /></a>Follow CleanTechnica <a href="https://news.google.com/publications/CAAqLQgKIidDQklTRndnTWFoTUtFV05zWldGdWRHVmphRzVwWTJFdVkyOXRLQUFQAQ?oc=3&amp;ceid=US:en">on Google News</a>.<br />
It will make you happy &#038; help you live in peace for the rest of your life.</p>
<p><span id="more-200440"><a href="https://future-trends.cleantechnica.com/subscribe/" target="_blank" rel="noopener"><img class="aligncenter size-full wp-image-155294" src="https://cleantechnica.com/files/2019/04/CleanTechnica_subscribe_banner_03.jpg" alt="" /></a><br />
</span></p>

    
    
<p class="omc-single-tags"><b>Tags:</b> <a href="https://cleantechnica.com/tag/auto-industry/" rel="tag">auto industry</a>, <a href="https://cleantechnica.com/tag/car-buying/" rel="tag">car buying</a>, <a href="https://cleantechnica.com/tag/china/" rel="tag">China</a>, <a href="https://cleantechnica.com/tag/coronavirus/" rel="tag">coronavirus</a>, <a href="https://cleantechnica.com/tag/covid-19/" rel="tag">COVID-19</a>, <a href="https://cleantechnica.com/tag/drone-delivery/" rel="tag">drone delivery</a>, <a href="https://cleantechnica.com/tag/drones/" rel="tag">drones</a>, <a href="https://cleantechnica.com/tag/geely/" rel="tag">geely</a>, <a href="https://cleantechnica.com/tag/geely-bo-rui/" rel="tag">geely bo rui</a>, <a href="https://cleantechnica.com/tag/lotus/" rel="tag">lotus</a>, <a href="https://cleantechnica.com/tag/volvo/" rel="tag">volvo</a><br /></p>

    
<br class="clear"/>

<div class="omc-authorbox">

    <h4>About the Author</h4>

    <div class="omc-author-pic"><a
        href="https://cleantechnica.com/author/joborras/"><img alt='' src='https://secure.gravatar.com/avatar/a57f27277f3d7314dea29e817573aecb?s=80&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/a57f27277f3d7314dea29e817573aecb?s=160&#038;d=identicon&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></a>
    </div>

    <p><a href="https://cleantechnica.com/author/joborras/" title="Posts by Jo Borrás" rel="author">Jo Borrás</a> I've been involved in motorsports and tuning since 1997, and have been a part of the Important Media Network since 2008.  You can find me here, working on my Volvo fansite, riding a motorcycle around Chicago, or chasing my kids around Oak Park.</p>

</div>

<br class="clear" />

<div class="omc-related-posts">

    <h4>Related Posts</h4>

        
                <article class="omc-related-post omc-module-c omc-quarter-width-category">

                    <a href="https://cleantechnica.com/2020/03/29/louisiana-is-in-horror-lack-of-medical-supplies-dire-plea-for-help/" title="Louisiana Is In Horror, Lack Of Medical Supplies Dire — Plea For Help">

                        <img src="https://cleantechnica.com/files/2020/03/Louisiana-coronavirus-COVID-19-epidemic-hospital-crisis-290x166.png" class="omc-image-resize wp-post-image" alt="" />
                    </a>

                    <h5 class="omc-related-article"><a href="https://cleantechnica.com/2020/03/29/louisiana-is-in-horror-lack-of-medical-supplies-dire-plea-for-help/"
                                                       title="Louisiana Is In Horror, Lack Of Medical Supplies Dire — Plea For Help">Louisiana Is In Horror, Lack Of Medical Supplies Dire — Plea For Help</a><span> &rarr;</span>
                    </h5>

                </article><!-- /omc-related-post -->

                
                <article class="omc-related-post omc-module-c omc-quarter-width-category">

                    <a href="https://cleantechnica.com/2020/03/29/covid-19-will-reshape-politics-in-the-usa-our-climate-will-benefit/" title="COVID-19 Will Reshape Politics In The USA, &#038; Our Climate Will Benefit">

                        <img src="https://cleantechnica.com/files/2019/07/Virus-1E-290x166.jpg" class="omc-image-resize wp-post-image" alt="" />
                    </a>

                    <h5 class="omc-related-article"><a href="https://cleantechnica.com/2020/03/29/covid-19-will-reshape-politics-in-the-usa-our-climate-will-benefit/"
                                                       title="COVID-19 Will Reshape Politics In The USA, &#038; Our Climate Will Benefit">COVID-19 Will Reshape Politics In The USA, &#038; Our Climate Will Benefit</a><span> &rarr;</span>
                    </h5>

                </article><!-- /omc-related-post -->

                
                <article class="omc-related-post omc-module-c omc-quarter-width-category">

                    <a href="https://cleantechnica.com/2020/03/29/no-one-is-buying-canadas-oil-a-preview-of-the-near-future-new-normal/" title="No One Is Buying Canada&#8217;s Oil: A Preview Of The Near Future New Normal">

                        <img src="https://cleantechnica.com/files/2020/03/athabasca_cover_iPad_1024x576-290x166.jpg" class="omc-image-resize wp-post-image" alt="Athabasca Alberta oil sands from space" />
                    </a>

                    <h5 class="omc-related-article"><a href="https://cleantechnica.com/2020/03/29/no-one-is-buying-canadas-oil-a-preview-of-the-near-future-new-normal/"
                                                       title="No One Is Buying Canada&#8217;s Oil: A Preview Of The Near Future New Normal">No One Is Buying Canada&#8217;s Oil: A Preview Of The Near Future New Normal</a><span> &rarr;</span>
                    </h5>

                </article><!-- /omc-related-post -->

                
                <article class="omc-related-post omc-module-c omc-quarter-width-category">

                    <a href="https://cleantechnica.com/2020/03/29/carmakers-to-the-rescue-n95-mask-mass-production/" title="Carmakers To The Rescue — N95 Mask Mass Production">

                        <img src="https://cleantechnica.com/files/2019/04/Tesla-seat-factory-fresh-31-290x166.jpg" class="omc-image-resize wp-post-image" alt="" />
                    </a>

                    <h5 class="omc-related-article"><a href="https://cleantechnica.com/2020/03/29/carmakers-to-the-rescue-n95-mask-mass-production/"
                                                       title="Carmakers To The Rescue — N95 Mask Mass Production">Carmakers To The Rescue — N95 Mask Mass Production</a><span> &rarr;</span>
                    </h5>

                </article><!-- /omc-related-post -->

                
            <br class="clear"/>

                
</div><!-- /omc-related-posts -->

<br class="clear"/>



    
<div id="disqus_thread"></div>

    		
	</article><!-- /omc-full-article -->

</section><!-- /omc-main -->

<section id="omc-sidebar" class="omc-right">

	<a href="#top" class="omc-mobile-back-to-top">Back to Top &uarr;</a>
	
	<ul class="xoxo">
		<li id="text-127" class="omc-widget widget_text"><h3 class="widgettitle"><span>Advertisement</span></h3>			<div class="textwidget"><div id="MM_CT_desktop_sidebar_300x250"></div>
</div>
		</li><li id="text-165" class="omc-widget widget_text">			<div class="textwidget"><p style="text-align: center;"><a href="http://cleantechnica.com/advertise/"><strong>Advertise with <em>CleanTechnica</em> to get your company in front of millions of monthly readers.</strong></a></p>
</div>
		</li><li id="text-171" class="omc-widget widget_text"><h3 class="widgettitle"><span>Power CleanTechnica &#8211; $3/Month</span></h3>			<div class="textwidget"><p><a href="https://future-trends.cleantechnica.com/subscribe/"><img class="aligncenter size-full wp-image-155293" src="https://cleantechnica.com/files/2018/08/CleanTechnica-Subscribers.jpg" alt="Tesla News Solar News EV News Data Reports" /></a></p>
</div>
		</li><li id="top-posts-3" class="omc-widget widget_top-posts"><h3 class="widgettitle"><span>Top News On CleanTechnica</span></h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://cleantechnica.com/2020/03/28/check-out-this-electric-vehicle-total-cost-of-ownership-calculator/" title="Check Out This Electric Vehicle Total Cost Of Ownership Calculator" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/cleantechnica.com/files/2020/03/Tesla-Model-3-Long-Range-AWD-vs-Volkswagen-Golf-R-TCO.png?resize=40%2C40&#038;ssl=1" alt="Check Out This Electric Vehicle Total Cost Of Ownership Calculator" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/28/check-out-this-electric-vehicle-total-cost-of-ownership-calculator/" title="Check Out This Electric Vehicle Total Cost Of Ownership Calculator" class="bump-view" data-bump-view="tp">Check Out This Electric Vehicle Total Cost Of Ownership Calculator</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/29/volkswagen-software-10-months-ago-vs-today/" title="Volkswagen Software Comments — 10 Months Ago vs. Today" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/cleantechnica.com/files/2019/09/Volkswagen-ID.3-white-interior-3.jpg?resize=40%2C40&#038;ssl=1" alt="Volkswagen Software Comments — 10 Months Ago vs. Today" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/29/volkswagen-software-10-months-ago-vs-today/" title="Volkswagen Software Comments — 10 Months Ago vs. Today" class="bump-view" data-bump-view="tp">Volkswagen Software Comments — 10 Months Ago vs. Today</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/28/tesla-model-y-vs-mercedes-amg-gle-63-s/" title="Tesla Model Y vs. Mercedes-AMG GLE 63 S" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/cleantechnica.com/files/2020/03/Tesla-Model-Y-Performance-Paul.jpg?resize=40%2C40&#038;ssl=1" alt="Tesla Model Y vs. Mercedes-AMG GLE 63 S" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/28/tesla-model-y-vs-mercedes-amg-gle-63-s/" title="Tesla Model Y vs. Mercedes-AMG GLE 63 S" class="bump-view" data-bump-view="tp">Tesla Model Y vs. Mercedes-AMG GLE 63 S</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/28/off-the-radar-renewable-energy-explosion-after-covid-19-dust-settles-ct-exclusive-background-interview/" title="Off-The-Radar Renewable Energy Explosion After COVID-19 Dust Settles — CleanTechnica Interview" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i1.wp.com/cleantechnica.com/files/2020/03/reneweable-energy-electric-grid.png?resize=40%2C40&#038;ssl=1" alt="Off-The-Radar Renewable Energy Explosion After COVID-19 Dust Settles — CleanTechnica Interview" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/28/off-the-radar-renewable-energy-explosion-after-covid-19-dust-settles-ct-exclusive-background-interview/" title="Off-The-Radar Renewable Energy Explosion After COVID-19 Dust Settles — CleanTechnica Interview" class="bump-view" data-bump-view="tp">Off-The-Radar Renewable Energy Explosion After COVID-19 Dust Settles — CleanTechnica Interview</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/29/tesla-cuts-jobs-in-nevada-sends-ventilators-to-new-york/" title="Tesla Cuts Jobs In Nevada, Sends Ventilators To New York" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i2.wp.com/cleantechnica.com/files/2019/03/tesla-model-y-unveiling-elon-musk-gf1-gigafactory-nevada.jpg?resize=40%2C40&#038;ssl=1" alt="Tesla Cuts Jobs In Nevada, Sends Ventilators To New York" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/29/tesla-cuts-jobs-in-nevada-sends-ventilators-to-new-york/" title="Tesla Cuts Jobs In Nevada, Sends Ventilators To New York" class="bump-view" data-bump-view="tp">Tesla Cuts Jobs In Nevada, Sends Ventilators To New York</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/29/2020-fiat-500e-all-new-electric-only-gallery/" title="2020 Fiat 500e — All-New &amp; Electric Only (Gallery)" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i1.wp.com/cleantechnica.com/files/2020/03/3541b930f3efbd2d14fd2e452fbdfa98184b0cc5.jpg?resize=40%2C40&#038;ssl=1" alt="2020 Fiat 500e — All-New &amp; Electric Only (Gallery)" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/29/2020-fiat-500e-all-new-electric-only-gallery/" title="2020 Fiat 500e — All-New &amp; Electric Only (Gallery)" class="bump-view" data-bump-view="tp">2020 Fiat 500e — All-New &amp; Electric Only (Gallery)</a>
							</div>
													</li>
										<li>
						<a href="https://cleantechnica.com/2020/03/27/tesla-the-china-connection/" title="Tesla &amp; The China Connection" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i1.wp.com/cleantechnica.com/files/2019/10/tesla-shanghai-gigafactory-gf3-team-employees-made-in-china-model-3-TESLA-OFFICIAL.png?resize=40%2C40&#038;ssl=1" alt="Tesla &amp; The China Connection" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleantechnica.com/2020/03/27/tesla-the-china-connection/" title="Tesla &amp; The China Connection" class="bump-view" data-bump-view="tp">Tesla &amp; The China Connection</a>
							</div>
													</li>
					</ul>
</li><li id="text-59" class="omc-widget widget_text"><h3 class="widgettitle"><span>Advertisement</span></h3>			<div class="textwidget"><p><center></p>
<div id="MM_CT_desktop_sidebar_300x600"></div>
<p></center></p>
</div>
		</li>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<li id="html_javascript_adder-51" class="omc-widget widget_html_javascript_adder"><h3 class="widgettitle"><span>Our Electric Car Driver Report</span></h3>
<div class="hjawidget textwidget">
<a href="https://future-trends.cleantechnica.com/reports/electric-car-drivers-demands-desires-dreams-2019/"><img src="https://cleantechnica.com/files/2019/12/Electric-Car-Drivers-Tesla-Drivers-Surveys-Report-CleanTechnica-2019.jpg" alt="" class="aligncenter size-full wp-image-121563" /></a>
<center>&nbsp;</center>
<center><em>Read our new report on <a href="https://future-trends.cleantechnica.com/reports/electric-car-drivers-demands-desires-dreams-2019/"><strong>electric car drivers, what they desire, and what they require</strong></a>.</em></center>

</div>
</li><!-- End - HTML Javascript Adder plugin v3.9 -->

<!-- Start - HTML Javascript Adder plugin v3.9 -->
<li id="html_javascript_adder-47" class="omc-widget widget_html_javascript_adder"><h3 class="widgettitle"><span>CleanTechnica Clothing &#038; Cups</span></h3>
<div class="hjawidget textwidget">
<a href="https://shop.spreadshirt.com/CleanTechnica" target="blank"><img class="aligncenter size-full wp-image-98182" src="https://cleantechnica.com/files/2019/11/Cleantech-news-EV-news-Tesla-news-CleanTechnica-Future-Is-Now-shirts.jpg" alt="EV shirts mugs" /></a>
</div>
</li><!-- End - HTML Javascript Adder plugin v3.9 -->
<li id="media_image-4" class="omc-widget widget_media_image"><h3 class="widgettitle"><span>Listen to CleanTech Talk</span></h3><a href="https://cleantechnica.com/cleantech-talk"><img width="350" height="342" src="https://cleantechnica.com/files/2019/09/CleanTech-Talk_with_log-w350px.jpg" class="image wp-image-191043  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://cleantechnica.com/files/2019/09/CleanTech-Talk_with_log-w350px.jpg 350w, https://cleantechnica.com/files/2019/09/CleanTech-Talk_with_log-w350px-270x264.jpg 270w, https://cleantechnica.com/files/2019/09/CleanTech-Talk_with_log-w350px-50x50.jpg 50w" sizes="(max-width: 350px) 100vw, 350px" /></a></li><li id="custom_html-2" class="widget_text omc-widget widget_custom_html"><h3 class="widgettitle"><span>Tesla News</span></h3><div class="textwidget custom-html-widget"><p><a href="https://cleantechnica.com/tag/tesla/"><img class="aligncenter wp-image-135081 size-full" src="https://cleantechnica.com/files/2019/09/Sarasota-Tesla-Model-3-Superchargers-White-Blue-National-Drive-Electric-Week-Sarasota-Florida-CleanTechnica.jpg" alt="" width="300" height="186" /></a></p>
</div></li>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<li id="html_javascript_adder-45" class="omc-widget widget_html_javascript_adder"><h3 class="widgettitle"><span>30 Electric Car Benefits</span></h3>
<div class="hjawidget textwidget">
<a href="https://cleantechnica.com/2019/06/16/30-reasons-to-buy-an-electric-car-today/" target="blank"><img class="aligncenter size-full wp-image-98182" src="https://cleantechnica.com/files/2016/09/electric-car-benefits.png" alt="Tesla Model 3 Video" /></a>
</div>
</li><!-- End - HTML Javascript Adder plugin v3.9 -->
<li id="custom_html-3" class="widget_text omc-widget widget_custom_html"><h3 class="widgettitle"><span>Our Electric Vehicle Reviews</span></h3><div class="textwidget custom-html-widget"><p><a href="https://cleantechnica.com/tag/ev-reviews/"><img src="https://cleantechnica.com/files/2017/12/Tesla-Model-X-News.jpg" alt="" class="aligncenter size-full wp-image-135082" /></a></p>
</div></li><li id="custom_html-5" class="widget_text omc-widget widget_custom_html"><h3 class="widgettitle"><span>EV Charging Guidelines for Cities</span></h3><div class="textwidget custom-html-widget"><p><a href="https://future-trends.cleantechnica.com/reports/electric-vehicle-charging-infrastructure-guidelines-cities/"><img src="https://cleantechnica.com/files/2018/09/EV-Charging-Guidelines-for-Cities-Cover-CleanTechnica.png" alt="" class="aligncenter size-full wp-image-121563" /></a><br />
<center><em>Read &#038; share our <strong>free</strong> report on &#8220;<a href="https://future-trends.cleantechnica.com/reports/electric-vehicle-charging-infrastructure-guidelines-cities/"><strong>EV charging guidelines for cities</strong></a>.&#8221;</em></center></p>
</div></li>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<li id="html_javascript_adder-60" class="omc-widget widget_html_javascript_adder"><h3 class="widgettitle"><span>Renewable Energy 101 In Depth</span></h3>
<div class="hjawidget textwidget">
<a href="https://cleantechnica.com/2020/02/08/the-beginners-guide-to-climate-change-renewables/" target="blank"><img class="aligncenter size-full wp-image-98182" src="https://cleantechnica.com/files/2020/03/have-a-sunny-day_1.jpg" alt="solar power facts" /></a>
</div>
</li><!-- End - HTML Javascript Adder plugin v3.9 -->

<!-- Start - HTML Javascript Adder plugin v3.9 -->
<li id="html_javascript_adder-46" class="omc-widget widget_html_javascript_adder"><h3 class="widgettitle"><span>38 Anti-Cleantech Myths</span></h3>
<div class="hjawidget textwidget">
<a href="https://cleantechnica.com/2016/09/02/renewable-energy-facts-electric-vehicle-facts-answers/" target="blank"><img class="aligncenter size-full wp-image-98182" src="https://cleantechnica.com/files/2019/01/290-cost-of-solar-cost-drop.jpg" alt="solar power facts" /></a>
</div>
</li><!-- End - HTML Javascript Adder plugin v3.9 -->
<li id="text-152" class="omc-widget widget_text"><h3 class="widgettitle"><span>Follow CleanTechnica</span></h3>			<div class="textwidget"><p><center><a href="https://twitter.com/cleantechnica" class="twitter-follow-button" data-show-count="true" data-size="large">Follow @cleantechnica</a><br />
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></center></p>
</div>
		</li><li id="facebook-likebox-2" class="omc-widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/CleanTechnica" data-width="300"  data-height="200" data-hide-cover="false" data-show-facepile="true" data-tabs="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/CleanTechnica"><a href="https://www.facebook.com/CleanTechnica"></a></blockquote></div>
		</div>
		</li><li id="text-125" class="omc-widget widget_text"><h3 class="widgettitle"><span>Advertisement</span></h3>			<div class="textwidget"><div id="MM_CT_desktop_sidebar_BTF_300x250"></div>
</div>
		</li>					

	</ul><!-- /xoxo -->

</section>	

<br class="clear" />
	
</div> <!--! end of #container -->
	
	<footer id="omc-boxed">
	<center><div id="MM_CT_desktop_bottom_970x90"></div></center>

		<div id="omc-footer-border"></div>
	
		<div id="omc-inner-footer">

			<div class="omc-footer-widget-column">
				
				<div class="omc-footer-widget">
				
										
						<div class="omc-footer-widget">
						
							<img src="https://cleantechnica.com/files/2013/07/Clean_Technica_Cleantech-Tesla-News-EV-Solar-News-Logo.png" alt="footer logo" class="footer-logo" />
							<br/>
														<a class="omc-social-small facebook" href="https://www.facebook.com/CleanTechnica"></a>							<a class="omc-social-small twitter" href="https://twitter.com/cleantechnica"></a>							<a class="omc-social-small linkedin" href="https://future-trends.cleantechnica.com/pictures/#"></a>														<a class="omc-social-small youtube" href="https://www.youtube.com/cleantechnica"></a>														
							<br class="clear"/>
							<p></p>
							
						</div><!-- /omc-footer-widget -->
					
										
							
				
				</div><!-- /omc-footer-widget -->
				
			</div><!--- /first-footer-column -->

			<div class="omc-footer-widget-column">
				
				<div id="text-173" class="omc-footer-widget widget_text">			<div class="textwidget"><p>CleanTechnica is the #1 cleantech-focused news &amp; analysis website in the US &amp; the world, focusing primarily on electric cars, solar energy, wind energy, &amp; energy storage.</p>
<p>News is published on <a href="https://cleantechnica.com/">CleanTechnica.com</a>, while reports are published on <a href="https://future-trends.cleantechnica.com/reports/">Future-Trends.CleanTechnica.com/Reports/</a> and buying guides are <a href="https://future-trends.cleantechnica.com/buying-guides/">here</a>.</p>
</div>
		</div><div id="text-110" class="omc-footer-widget widget_text">			<div class="textwidget"><p><script src="https://apis.google.com/js/platform.js" async defer></script></p>
<div class="g-page" data-href="//plus.google.com/u/0/113322468625393787142" data-rel="publisher"></div>
</div>
		</div>		
					
			</div><!--- /second-footer-column -->

			<div class="omc-footer-widget-column">
				
				<div id="text-123" class="omc-footer-widget widget_text">			<div class="textwidget"><p>The content produced by this site is for entertainment purposes only. Opinions and comments published on this site may not be sanctioned by and do not necessarily represent the views of CleanTechnica, its owners, sponsors, affiliates, or subsidiaries.</p>
</div>
		</div>		
					
			</div><!--- /third-footer-column -->

			<div class="omc-footer-widget-column no-right">
				
						
					
			</div><!--- /fourth-footer-column -->
			
			<br class="clear" />
		
		</div><!-- /omc-inner-footer -->
		
	</footer>
	
		
		<div class="omc-copyright-area">
			
			<div class="omc-copyright-left">
				
				<p>&copy; 2020 &nbsp; CleanTechnica</p>
				
			</div><!-- /omc-copyright-left -->
			
			<div class="omc-copyright-right">
				
				<div class="omc-copyright-menu"><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170631"><a href="https://cleantechnica.com/invest/">Invest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132206"><a href="http://products.cleantechnica.com/cars">Electric Cars</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136011"><a href="https://cleantechnica.com/2016/08/31/30-reasons-next-car-electric/">Electric Car Benefits</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136012"><a href="https://cleantechnica.com/tag/ev-sales/">Electric Car Sales</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-133660"><a href="https://cleantechnica.com/2013/10/08/advantages-disadvantages-solar-power/">Solar Energy Rocks</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79707"><a href="http://cleantechnica.com/feed">RSS</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55793"><a href="http://cleantechnica.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148986"><a href="https://cleantechnica.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>				
				<br class="clear" />
				
			</div><!-- /omc-copyright-right -->
			
			<br class="clear" /> 
		<a href="#top" class="omc-mobile-back-to-top omc-bottom-b-t-t">Back to Top &uarr;</a>	
		</div><!-- /omc-copyright-area -->
		
		

	<p id="back-top"><a href="#top"><span></span></a></p>

	<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-MXx1pMvJa8BJY"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-MXx1pMvJa8BJY.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7521787" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=7521787&cv=2.0&cj=1" />
</noscript><script type='text/javascript' src='https://cleantechnica.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"","version":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"im-cleantechnica"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"205484 https:\/\/cleantechnica.com\/?p=205484","disqusShortname":"im-cleantechnica","disqusTitle":"Drone Delivery By Geely: Selling Cars In The Age Of COVID-19","disqusUrl":"https:\/\/cleantechnica.com\/2020\/03\/29\/drone-delivery-by-geely-selling-cars-in-the-age-of-covid-19\/","postId":"205484"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/zendy-video-resizer/zendy-video-resizer.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cleantechnica.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.2',blog:'13821326',post:'205484',tz:'-4',srv:'cleantechnica.com'} ]);
	_stq.push([ 'clickTrackerInit', '13821326', '205484' ]);
</script>
			
				<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});
				</script>
			
			<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies:  <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://cleantechnica.com/privacy-policy/">Find out more.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Okay, thanks</button></span></div><!-- custom wrapper class --></div><!-- #catapult-cookie-bar -->
	<!--[if lt IE 7 ]>
		<script src="//ajax.googleapis.com/ajax/libs/chrome-frame/1.0.2/CFInstall.min.js"></script>
		<script>window.attachEvent("onload",function(){CFInstall.check({mode:"overlay"})})</script>
	<![endif]-->

	</div><!-- /transparent-layer -->
	
		
</body>

</html>
